Help||Problem using a method "SendAndLoad"

Need help with SmartFoxServer? You didn't find an answer in our documentation? Please, post your questions here!

Moderators: Lapo, Bax

ransaymour
Posts: 10
Joined: 20 Jun 2016, 18:30

Help||Problem using a method "SendAndLoad"

Postby ransaymour » 15 Jan 2017, 15:42

I looked in the forum to find a solution, and I saw that other people have the same problem that the received data is undefined anyone know how to fix it?
User avatar
Lapo
Site Admin
Posts: 19202
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: Help||Problem using a method "SendAndLoad"

Postby Lapo » 16 Jan 2017, 09:24

Hi,
can you give me the details of what you're doing? In other words the server side code that you're using and what output is generated by the remote service you're calling?

Thanks
Lapo
--
gotoAndPlay()
...addicted to flash games
ransaymour
Posts: 10
Joined: 20 Jun 2016, 18:30

Re: Help||Problem using a method "SendAndLoad"

Postby ransaymour » 11 Apr 2017, 15:57

Lapo wrote:Hi,
can you give me the details of what you're doing? In other words the server side code that you're using and what output is generated by the remote service you're calling?

Thanks




server side code :

Code: Select all

function handleRequest(cmd, params, user, fromRoom)
{
   if (cmd == "get")
   {
   var _send = new LoadVars()
   var _load = new LoadVars()
   
   // Set parameters to send
    var   username =  params["username"]
   var   pass = params["pass"]
   trace(pass  username)
   _send.username = username
   _send.pass    = pass
   
 
   // Handle the remote data
   _load.onLoad = function(success, errorMsg)
   {
      if (success)
      {
         trace("success")
      }
      else
      {
         trace("Loadvar Failed. " + errorMsg)
      }
   }
   _send.sendAndLoad("https://www.tipost.co.il/chat/Include/Pages/CheckUser.php", _load, "POST")
   
   
   }
   
   }

I get this message: "Loadvar Failed. I / O Error: Received fatal alert: internal_error"
User avatar
Lapo
Site Admin
Posts: 19202
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: Help||Problem using a method "SendAndLoad"

Postby Lapo » 20 Apr 2017, 10:31

You're receiving an error because it was generated by the remote server you're talking to.
The call causes an HTTP error 403, which looks like a security issue.

If you analyze the traffic you will find that the remote server is returning an HTTP page with the detail of the problem. Among other things it says this:
The owner of this website (http://www.tipost.co.il) has banned your access based on your browser's signature (3527738b54863d95-ua21).<

And it continues saying that you've been banned by IP address.

Are you sure you have permission to talk to this server? If so I think you should talk to the hosting company and ask why the server is banning you.

Cheers
Lapo

--

gotoAndPlay()

...addicted to flash games
ransaymour
Posts: 10
Joined: 20 Jun 2016, 18:30

Re: Help||Problem using a method "SendAndLoad"

Postby ransaymour » 20 Apr 2017, 14:55

The site is managed by me, maybe because it was sent in HTTPS protocol?
User avatar
Lapo
Site Admin
Posts: 19202
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: Help||Problem using a method "SendAndLoad"

Postby Lapo » 20 Apr 2017, 15:34

I don't think so.
I tested using HTTP (not HTTPS) so that I could see the traffic going on between the two sides.

I'd recommend you do the same if you want to see the error in detail. It looks like you need some configuration steps on your side.

cheers
Lapo

--

gotoAndPlay()

...addicted to flash games

Return to “SmartFoxServer 1.x Discussions and Help”

Who is online

Users browsing this forum: No registered users and 6 guests