Please test this one with Unity 3 - 1.2.7 rc1

Post here all your questions related with SmartFoxServer .Net/Unity3D API

Moderators: Bax, Lapo

Please test this one with Unity 3 - 1.2.7 rc1

Postby ThomasLund » 28 Sep 2010, 06:16

Hi people

I removed the CultureInfo stuff from the dll and would love if someone could give this a test run in their projects as a sanity check:

http://www.fullcontrol.dk/downloads/sfs ... .7-rc1.dll

Only change is the Unity 3 webplayer fix. If there are other bugs they should be a problem with parsing floating points either client->server or server->client. "But it should work" (tm)

Thanks!!

/Thomas
Last edited by ThomasLund on 30 Oct 2010, 08:04, edited 1 time in total.
ThomasLund
 
Posts: 1297
Joined: 14 Mar 2008, 07:52
Location: Sweden

Postby stevets » 28 Sep 2010, 07:00

Hi Thomas,

I did a quick test on Unity3 RC5 using the SFSIsland Demo.
The webplayer works with your fix.

Thanks again,
Steve
stevets
 
Posts: 60
Joined: 11 Jul 2010, 12:22
Location: USA

Postby appels » 28 Sep 2010, 12:33

Thomas, is this a different one then the one I got ?
appels
 
Posts: 464
Joined: 28 Jul 2010, 02:12

Postby ThomasLund » 28 Sep 2010, 12:36

A little, but not much. Previous one should be discarded.
ThomasLund
 
Posts: 1297
Joined: 14 Mar 2008, 07:52
Location: Sweden

Postby appels » 28 Sep 2010, 12:47

seems to work just fine. tested in chrome, IE, FF
appels
 
Posts: 464
Joined: 28 Jul 2010, 02:12

I will test

Postby matrix211v1 » 28 Sep 2010, 14:55

I will test in about 6 hours. The issue I had was joining rooms again. It worked in Unity 2.6.1 with the 1.2.6 API. I keep getting a e:\ error. (Sorry, cannot remember the exact error, but it was mapped to someone e:\ drive)

[EDIT]

6 hours later I'm home and I can say that it seems to work fine.
matrix211v1
 
Posts: 61
Joined: 16 Jan 2009, 14:48

Postby ThomasLund » 01 Oct 2010, 12:09

Super - will poke Marco about getting this released officially then

/Thomas
ThomasLund
 
Posts: 1297
Joined: 14 Mar 2008, 07:52
Location: Sweden

Postby daqulazhang » 25 Mar 2011, 09:45

Hi,
Is that means, without 1.2.7, we can't let our server work with Unity3.x webplayer?
Because I am now experiencing updating unity project from 2.6 to 3.3, and Bam! I got stuck even in connect to smartfox server when use webplayer mode.. I am using 1.2.6 plugin and smartfox 1.6.6.

This is terrible, is there anyone else met similar issue with me?
daqulazhang
 
Posts: 6
Joined: 21 Sep 2009, 06:48

Postby ThomasLund » 25 Mar 2011, 09:52

That is totally correct. 1.2.7 is required for 3.x webplayer builds in addition to adding the prefetch policyfile line you need to add if you want to use SFS policy serving

/Thomas
Full Control - maker of Unity/C# and Java SFS API and indie games
Follow on twitter: http://twitter.com/thomas_h_lund
ThomasLund
 
Posts: 1297
Joined: 14 Mar 2008, 07:52
Location: Sweden

Postby agrios » 11 Jul 2011, 03:23

Will 1.2.7 work with Unity 3.4 ?
agrios
 
Posts: 18
Joined: 20 Oct 2010, 20:42

Postby ThomasLund » 11 Jul 2011, 04:38

I dont know!

Only one way to find out (actually two, but this time around there is only one) - try it when they release 3.4

With that said I doubt that it should not work - afaik the mono library used isnt changed

/T
Full Control - maker of Unity/C# and Java SFS API and indie games
Follow on twitter: http://twitter.com/thomas_h_lund
ThomasLund
 
Posts: 1297
Joined: 14 Mar 2008, 07:52
Location: Sweden

Thomas

Postby maxfelker » 19 Aug 2011, 17:41

Just updated to Unity 3.4 and was about to starting hacking away on the SFS integration. Any update on the compatibility?

Thanks!
maxfelker
 
Posts: 3
Joined: 01 Apr 2011, 22:21

Postby ThomasLund » 21 Aug 2011, 11:59

If you just started out on SFS, you should most likely use SFS2X instead of SFS1 (imho).

More functionality, more support, better performance for less €

/T
Full Control - maker of Unity/C# and Java SFS API and indie games
Follow on twitter: http://twitter.com/thomas_h_lund
ThomasLund
 
Posts: 1297
Joined: 14 Mar 2008, 07:52
Location: Sweden

Re: Please test this one with Unity 3 - 1.2.7 rc1

Postby ThomasLund » 17 May 2012, 14:42

In case you still need this, I've re-arranged my website and made it new and shiny. Thus the link to the 1.2.7 dll isnt valid anymore.

On a request from someone I uploaded the latest sources and compiled dll to here:

http://fullcontrol.dk/upload/sfs1/

There are no plans to continue work on the SFS1 dll unless someone find a critical bug. Please consider using SFS2X which is actively maintained

/Thomas
Full Control - maker of Unity/C# and Java SFS API and indie games
Follow on twitter: http://twitter.com/thomas_h_lund
ThomasLund
 
Posts: 1297
Joined: 14 Mar 2008, 07:52
Location: Sweden


Return to .Net / Unity3D API

Who is online

Users browsing this forum: No registered users and 1 guest