Strange error

Post here your questions about the OpenSpace 2.x or notify bugs and suggestions.

Moderators: Lapo, Bax

Madhav
Posts: 78
Joined: 27 Nov 2012, 04:41

Strange error

Postby Madhav » 14 Jun 2013, 11:34

Hi,
when loading a openspace map i am getting this strange error.

TypeError: Error #1009: Cannot access a property or method of a null object reference.
at com.smartfoxserver.openspace.engine.control::IsoEngineController/http://www.smartfoxserver.com/openspace/osInternal::setGhostPosition()
at com.smartfoxserver.openspace.engine.control.avatar::AvatarAnimator/adjustAvatarRendering()
at com.smartfoxserver.openspace.engine.control.avatar::AvatarAnimator/onAvatarAnimationStep()
at Function/http://adobe.com/AS3/2006/builtin::apply()
at com.greensock::TweenMax/renderTime()
at com.greensock.core::SimpleTimeline/renderTime()
at com.greensock::TweenLite$/updateAll()

Please help me sort this out
User avatar
Bax
Site Admin
Posts: 4332
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

Re: Strange error

Postby Bax » 14 Jun 2013, 12:54

Without a line number it is quite difficult to sort this out.
Are you using the ghost avatar?
Can you better describe how the error appears? Step-by-step instructions since you start your application for the first time.
Paolo Bax
The SmartFoxServer Team
Madhav
Posts: 78
Joined: 27 Nov 2012, 04:41

Re: Strange error

Postby Madhav » 03 Jul 2013, 10:30

Hi Bax, sorry for such late reply...
I am using ghost avatar.

This error is not server a side error, rather is at the client side.

Step-by-step instructions is as follows,
1. I enter username,password- connect to smartFox, join the zone and subsequently a room which is a openspace serverside map.
2. I click on a home icon on stage.
3. Request is sent to custom extension which extends openspace extension which in turn creates a duplicate map of original map and also creates a dynamic room and assigns room variables and sends avatar to map.
4.while in home map I try to come outside by walking on certain tiles whoes trigers call a function which loads last joined room.
At this point everything works as expected but this strange error occurs.

Thanx in advance...
User avatar
Bax
Site Admin
Posts: 4332
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

Re: Strange error

Postby Bax » 11 Jul 2013, 08:06

We will look into it as soon as possible, trying to replicate your steps.
Anyway if I understand correctly, this error is not causing harm, as the player can keep navigating the virtual world as expected, right?
Paolo Bax
The SmartFoxServer Team
Madhav
Posts: 78
Joined: 27 Nov 2012, 04:41

Re: Strange error

Postby Madhav » 11 Jul 2013, 08:51

yap, true
User avatar
Bax
Site Admin
Posts: 4332
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

Re: Strange error

Postby Bax » 04 Sep 2013, 11:04

We tested the scenario you described above, using both the "enterTile" and the "stopMove" avatar event types, but we are not able to reproduce this issue.
No error (and in particular no one connected to the ghost avatar) is fired when the avatar jumps on the tile and the new map is loaded.
Paolo Bax
The SmartFoxServer Team

Return to “OpenSpace v2 discussions and help”

Who is online

Users browsing this forum: No registered users and 2 guests