strange network peaks

Post here your questions about SFS2X. Here we discuss all server-side matters. For client API questions see the dedicated forums.

Moderators: Lapo, Bax

Tatanan
Posts: 109
Joined: 07 Jan 2014, 12:12
Contact:

strange network peaks

Postby Tatanan » 19 May 2017, 18:59

Hi,

Suddenly we register strange network peaks the makes user not receive messages or they receive the messages after many many seconds, and the extension queue grows to strange values. It seems that during some time the server can not send any message.
Any idea? How can I monitor if an extension handler is slow?
I Attach some graphs from the Admin Tool.
screenshot network.png
(46.42 KiB) Not downloaded yet

screenshot queue.png
(52.46 KiB) Not downloaded yet

screenshot cpu.png
(40.7 KiB) Not downloaded yet
User avatar
Lapo
Site Admin
Posts: 19630
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: strange network peaks

Postby Lapo » 20 May 2017, 09:37

Hi,
one instance is not enough to understand if this is a real issue or a temporary "hiccup".
The spike might have been anything, from a garbage collection cycle to something external to the JVM, such as another process suddenly reducing the available CPU and slowing everything down.

Does this happen at regular times? Or is it dependent on server load?

thanks
Lapo
--
gotoAndPlay()
...addicted to flash games
Tatanan
Posts: 109
Joined: 07 Jan 2014, 12:12
Contact:

Re: strange network peaks

Postby Tatanan » 31 May 2017, 08:52

Solved. It was a problem with the database.

Thanks you anyway and
sorry for the inconvenience
User avatar
Lapo
Site Admin
Posts: 19630
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: strange network peaks

Postby Lapo » 31 May 2017, 13:45

No problem, glad you find out what caused it. :)

cheers
Lapo

--

gotoAndPlay()

...addicted to flash games

Return to “SFS2X Questions”

Who is online

Users browsing this forum: No registered users and 5 guests