error after [_smartFox loadConfig....] when integrating FB

Post here your questions about the Objective-C API for SFS2X

Moderators: Lapo, Bax

zzc11414
Posts: 59
Joined: 26 Jun 2012, 03:17

error after [_smartFox loadConfig....] when integrating FB

Postby zzc11414 » 16 Aug 2012, 13:04

I am integrating smartfox and facebook(I use hackbook example code in facebook sdk) in ios platform. After call "[_smartFox loadConfig:@"configRegistration.xml" connectOnSuccess:YES]; " I get an error:NSStream getStreamsToHostNamed:port:inputStream:outputStream:]: unrecognized selector sent to class ...

If I don't integrating smartfox2x and facebook,That is to say,there is no facebook api integrated in the project,There is no the error above.everything is ok.

The debug log is as following.

2012-08-16 20:08:19.595 Hackbook[195:607] [SFS - INFO]SFS2X API version: 1.0.4
2012-08-16 20:08:19.653 Hackbook[195:607] +[NSStream getStreamsToHostNamed:port:inputStream:outputStream:]: unrecognized selector sent to class 0x3fd774b4
2012-08-16 20:08:19.686 Hackbook[195:607] *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '+[NSStream getStreamsToHostNamed:port:inputStream:outputStream:]: unrecognized selector sent to class 0x3fd774b4'
*** Call stack at first throw:
(
0 CoreFoundation 0x372a464f __exceptionPreprocess + 114
1 libobjc.A.dylib 0x33961c5d objc_exception_throw + 24
2 CoreFoundation 0x372a823b +[NSObject(NSObject) doesNotRecognizeSelector:] + 102
3 CoreFoundation 0x372a7649 ___forwarding___ + 508
4 CoreFoundation 0x3721e180 _CF_forwarding_prep_0 + 48
5 Hackbook 0x00025469 -[BitSwarmClient connect:port:] + 364
6 Hackbook 0x000431d7 -[SmartFox2XClient connect:port:] + 446
7 Hackbook 0x00042efd -[SmartFox2XClient onConfigLoadSuccess:] + 748
8 Hackbook 0x00027191 -[ConfigLoader loadConfig:delegate:] + 1048
9 Hackbook 0x00043297 -[SmartFox2XClient loadConfig:connectOnSuccess:] + 82
10 Hackbook 0x00006841 -[HackbookAppDelegate beginConnect] + 440
11 Hackbook 0x000031a5 -[HackbookAppDelegate application:didFinishLaunchingWithOptions:] + 916
12 UIKit 0x3120d821 -[UIApplication _callInitializationDelegatesForURL:payload:suspended:] + 772
13 UIKit 0x31207b65 -[UIApplication _runWithURL:payload:launchOrientation:statusBarStyle:statusBarHidden:] + 272
14 UIKit 0x311dc7d7 -[UIApplication handleEvent:withNewEvent:] + 1114
15 UIKit 0x311dc215 -[UIApplication sendEvent:] + 44
16 UIKit 0x311dbc53 _UIApplicationHandleEvent + 5090
17 GraphicsServices 0x31b67e77 PurpleEventCallback + 666
18 CoreFoundation 0x3727ba97 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE1_PERFORM_FUNCTION__ + 26
19 CoreFoundation 0x3727d83f __CFRunLoopDoSource1 + 166
20 CoreFoundation 0x3727e60d __CFRunLoopRun + 520
21 CoreFoundation 0x3720eec3 CFRunLoopRunSpecific + 230
22 CoreFoundation 0x3720edcb CFRunLoopRunInMode + 58
23 UIKit 0x31206d49 -[UIApplication _run] + 372
24 UIKit 0x31204807 UIApplicationMain + 670
User avatar
Lapo
Site Admin
Posts: 19607
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: error after [_smartFox loadConfig....] when integrating

Postby Lapo » 17 Aug 2012, 08:56

Moved to the correct forum section.
Lapo
--
gotoAndPlay()
...addicted to flash games
zzc11414
Posts: 59
Joined: 26 Jun 2012, 03:17

Re: error after [_smartFox loadConfig....] when integrating

Postby zzc11414 » 17 Aug 2012, 13:05

I have solved this problem .I am stupid .
Zammy
Posts: 29
Joined: 05 Aug 2014, 16:37

Re: error after [_smartFox loadConfig....] when integrating

Postby Zammy » 06 Aug 2014, 08:48

Would you share how you fixed it?

Return to “SFS2X iPhone / iPad / OSX API”

Who is online

Users browsing this forum: No registered users and 1 guest