Possible Issue with xcode 5.1 and client

Post here your questions about the Objective-C API for SFS2X

Moderators: Lapo, Bax

efsnet
Posts: 55
Joined: 14 Nov 2013, 20:48

Possible Issue with xcode 5.1 and client

Postby efsnet » 24 Mar 2014, 14:20

Hello,

Recently we upgraded to xcode to 5.1 and unfortunately there were a series of build errors upon compilation for the 64bit sim/iphone 5s. Has anyone else reported issues post xcode upgrade?

The errors are similar to below and appear during the link step:

Code: Select all

  Undefined symbols for architecture x86_64:
  "_OBJC_CLASS_$_CreateRoomRequest", referenced from:
      objc-class-ref in RoomController.o


Thanks,
-Eric
User avatar
Lapo
Site Admin
Posts: 19599
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: Possible Issue with xcode 5.1 and client

Postby Lapo » 24 Mar 2014, 18:42

I have used and tested our latest API (1.3.5) with XCode 5.1. Everything works fine.
You shouldn't have any problems with a relatively recent release such as an 1.3.x... try cleaning the "Derived Data" of your project from the Organizer and see if it helps.

Thanks
Lapo
--
gotoAndPlay()
...addicted to flash games
efsnet
Posts: 55
Joined: 14 Nov 2013, 20:48

Re: Possible Issue with xcode 5.1 and client

Postby efsnet » 24 Mar 2014, 20:05

Did you explicitly test using a 64bit sim/phone?

The build works unless using a 64 bit device...
User avatar
Lapo
Site Admin
Posts: 19599
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: Possible Issue with xcode 5.1 and client

Postby Lapo » 25 Mar 2014, 08:24

Thanks. I have noticed now.
We'll investigate.
Lapo

--

gotoAndPlay()

...addicted to flash games
efsnet
Posts: 55
Joined: 14 Nov 2013, 20:48

Re: Possible Issue with xcode 5.1 and client

Postby efsnet » 03 Apr 2014, 14:01

Hello,

Do you have a status update on this?

Thanks,
-Eric
User avatar
Lapo
Site Admin
Posts: 19599
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: Possible Issue with xcode 5.1 and client

Postby Lapo » 04 Apr 2014, 08:10

UPDATE: Can you try this and tell us if it solves the problem?
1. Select the target
2. Select “Build Settings”
3. Go to the “architectures” section and edit Architectures
4. Remove the default value $(ARCH_STANDARD)
5. Add armv7, armv7s
6. Clean the project
7. Build the project and it should now build correctly for the 64-bit architecture

See attached picture
PastedGraphic-1.png
(30.55 KiB) Not downloaded yet
Lapo

--

gotoAndPlay()

...addicted to flash games
efsnet
Posts: 55
Joined: 14 Nov 2013, 20:48

Re: Possible Issue with xcode 5.1 and client

Postby efsnet » 04 Apr 2014, 20:29

This resolved the build issue.

My understanding is that the new arm64 option was added for the 5.1 update, are there plans to add the ability to build against this architecture?

Thanks,
-Eric
User avatar
Lapo
Site Admin
Posts: 19599
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: Possible Issue with xcode 5.1 and client

Postby Lapo » 05 Apr 2014, 09:18

We'll be working on this for the next update.
Lapo

--

gotoAndPlay()

...addicted to flash games
User avatar
Lapo
Site Admin
Posts: 19599
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: Possible Issue with xcode 5.1 and client

Postby Lapo » 06 May 2014, 10:12

UPDATE:
We have just released an update, version 1.3.5a that adds support for the arm64 architecture.

You can download the update from the usual page:
http://www.smartfoxserver.com/download/sfs2x#p=client
Lapo

--

gotoAndPlay()

...addicted to flash games

Return to “SFS2X iPhone / iPad / OSX API”

Who is online

Users browsing this forum: No registered users and 3 guests