NetConnection.Connect.InvalidApp

Post your questions and bug-reports about the audio/video streaming add-on based on Red5 Media Server.

Moderators: Bax, Lapo, rjgtav

NetConnection.Connect.InvalidApp

Postby allenb » 16 Mar 2010, 23:31

I know this has been covered, but I've looked at all of the posts I can find and still don't see an answer that applies to my situation. Or perhaps my brain has turned to pudding after all this looking!

I installed SFSPro and am merely trying to run the examples as they were delivered. When I first ran them, everything with the video examples seemed to work fine. It was late, so I went to bed to continue in the morning. Restarted my computer and BAM, they don't work any more. Weird. I tried running SFSPro on a development server that is sitting here in the room with me. Same thing. Worked...then didn't.

The specifics:
Running SmartVideoConference I'm getting NetConnection.Connect.InvalidApp. RedBox is reporting serverReady. I just have no idea what else to look at now.

Client machine:
Windows 7
Apache 2
Flex Builder 3
Latest SFS

Server 1:
Same as above (trying to make it work on localhost...have tried changing between 127.0.0.1 and localhost to see if there was something strange going on there...no luck)

Server 2:
Ubuntu
Apache 2
Latest SFS
allenb
 
Posts: 2
Joined: 16 Mar 2010, 22:59

Postby Lapo » 19 Mar 2010, 10:48

Hi, it probably depends on how you are running the examples.
To simplify testing we provide a friendly browser-based interface where you can run the examples and test them locally on your computer.

If you have SFS PRO 1.6.6+ simply point your browser to localhost:8080, install the examples with one click and run them.

The examples run out of the box on the localhost but they will need to be edited to allow other clients from outside to connect.
This is done for security and to avoid that someone running a production server (and has forgotten the installed examples) is serving all those examples to the world :)
Lapo
--
gotoAndPlay()
...addicted to flash games
User avatar
Lapo
Site Admin
 
Posts: 15672
Joined: 21 Mar 2005, 09:50
Location: Italy

Postby allenb » 26 Mar 2010, 16:58

This is what has me baffled. I am running them on my local box. From what you said, I can see why they aren't working when I run SFS on another server, but I'm getting a failure on netconnection even when I'm running SFS locally. Again, the really weird thing about it is that it worked when I first installed everything, but then stopped working when I came back to it in the morning.

I guess I'll uninstall everything and start from scratch again.
allenb
 
Posts: 2
Joined: 16 Mar 2010, 22:59


Return to RedBox

Who is online

Users browsing this forum: No registered users and 1 guest