Default install: Errors found in config files

Need help with SmartFoxServer? You didn't find an answer in our documentation? Please, post your questions here!

Moderators: Lapo, Bax

eddiejones
Posts: 8
Joined: 14 Apr 2012, 23:33

Default install: Errors found in config files

Postby eddiejones » 14 Apr 2012, 23:42

I've installed sfs as per the instructions from the book I bought (flash multiplayer virtual worlds) and from the docs but I keep getting an error. Something about the configuration files having an error. The strange thing is that the first time I ran the server yesterday everything worked fine. After turning off my server for the night (because of noise problems) sfs no longer works. I've tried reinstalling sfs and java but with no luck. I'm starting to despise sfs.

here's the output from shell:


[internalDbDemo.as]: Initing dbExtension

java.lang.NullPointerException
at it.gotoandplay.smartfoxserver.data.buddylist.persistence.AdvancedBuddyListPersister.checkIfTableExists(AdvancedBuddyListPersister.java:270)
at it.gotoandplay.smartfoxserver.data.buddylist.persistence.AdvancedBuddyListPersister.init(AdvancedBuddyListPersister.java:40)
at it.gotoandplay.smartfoxserver.SmartFoxServer.setupZone(SmartFoxServer.java:1896)
at it.gotoandplay.smartfoxserver.lib.ConfigReader.parse_Zones(ConfigReader.java:806)
at it.gotoandplay.smartfoxserver.lib.ConfigReader.readZoneConfig(ConfigReader.java:174)
at it.gotoandplay.smartfoxserver.SmartFoxServer.initServerSocket(SmartFoxServer.java:339)
at it.gotoandplay.smartfoxserver.SmartFoxServer.run(SmartFoxServer.java:607)
Problems in config file: null
it.gotoandplay.smartfoxserver.exceptions.ConfigurationException
at it.gotoandplay.smartfoxserver.lib.ConfigReader.readZoneConfig(ConfigReader.java:199)
at it.gotoandplay.smartfoxserver.SmartFoxServer.initServerSocket(SmartFoxServer.java:339)
at it.gotoandplay.smartfoxserver.SmartFoxServer.run(SmartFoxServer.java:607)

Errors found in configuration files.
Unable to start the server.


Shutting down server...
Java noob
eddiejones
Posts: 8
Joined: 14 Apr 2012, 23:33

Re: Default install: Errors found in config files

Postby eddiejones » 15 Apr 2012, 00:44

Well, I fixed the problem. did ps aux | grep fox in shell and saw that there were a ton of processes for sfs. rebooted and now it works again. What a piece of junk. You would think that because this is a common problem that there would at least be a decent error message. :C
Java noob
User avatar
rjgtav
Posts: 2813
Joined: 19 Apr 2009, 11:31
Location: Lisbon, Portugal

Re: Default install: Errors found in config files

Postby rjgtav » 15 Apr 2012, 21:51

Well, it would be really hard to find that that error resulted from multiple sfs instances running... That probably happened because sfs could no longer connect to the database or find the specified table. Next time first please make sure that there are no multiple instances running, as it can cause the most weird problems you may ever find ;)
Skills: SFS Pro, SFS2X, AS2.0/AS3.0, Java, HTML5/CSS3/JS, C#
Portfolio: https://rjgtav.wordpress.com/
SFS Tutorials: http://sfs-tutor.blogspot.com/ - Discontinued. Some examples may be bugged.
Hypno7767
Posts: 1
Joined: 02 Nov 2020, 13:27

Re: Default install: Errors found in config files

Postby Hypno7767 » 02 Nov 2020, 13:29

I stopped wrapper.exe through Task Manager and ran it again and it worked. I think this would help a lot of people who followed someone's very undescriptive tutorial and now can't run their server.

Return to “SmartFoxServer 1.x Discussions and Help”

Who is online

Users browsing this forum: Google [Bot] and 44 guests