Added H2EnginePort directive, now won't connect

Need help with SmartFoxServer? You didn't find an answer in our documentation? Please, post your questions here!

Moderators: Lapo, Bax

lazybearsoft
Posts: 4
Joined: 15 Apr 2020, 00:59

Added H2EnginePort directive, now won't connect

Postby lazybearsoft » 15 Apr 2020, 01:09

I'm using SMS PRO 1.6.6, installing two instances on my Windows 10 PC. Trying to change the internal H2 port number on one of the instances using the H2EnginePort directive. I have tried several values, 9010, 9008, etc....but unless I use the default port , I always get:

DB Manager Activated ( org.h2.Driver )
17:53:10.418 - [ SEVERE ] > DbManager could not retrive a connection. org.h2.jdbc.JdbcSQLException: Connection is broken [90067-60]
it.gotoandplay.smartfoxserver.exceptions.DbManagerException: The Test SQL statement failed! Please check your configuration.
at it.gotoandplay.smartfoxserver.SmartFoxServer.setupZone(SmartFoxServer.java:1843)
at it.gotoandplay.smartfoxserver.lib.ConfigReader.parse_Zones(ConfigReader.java:806)
at it.gotoandplay.smartfoxserver.lib.ConfigReader.readZoneConfig(ConfigReader.java:174)
at it.gotoandplay.smartfoxserver.SmartFoxServer.initServerSocket(SmartFoxServer.java:339)
at it.gotoandplay.smartfoxserver.SmartFoxServer.run(SmartFoxServer.java:607)
Problems in config file: The Test SQL statement failed! Please check your configuration.
it.gotoandplay.smartfoxserver.exceptions.ConfigurationException: The Test SQL statement failed! Please check your configuration.
at it.gotoandplay.smartfoxserver.lib.ConfigReader.readZoneConfig(ConfigReader.java:199)
at it.gotoandplay.smartfoxserver.SmartFoxServer.initServerSocket(SmartFoxServer.java:339)
at it.gotoandplay.smartfoxserver.SmartFoxServer.run(SmartFoxServer.java:607)

Please help....it's imperative that I get 2 SFS instances running locally....I can't run them remotely, because there's a bug in UNity Mono debugger that makes the crossdomain policy always fail (but crossdomain works fine outside of debugger). But of course, I need to be able to use the debugger at times, and I can't change my Unity or Mono versions...so I am stuck with trying to get both SFS instances running locally.
User avatar
Lapo
Site Admin
Posts: 21952
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: Added H2EnginePort directive, now won't connect

Postby Lapo » 15 Apr 2020, 09:18

Hi,
check your active Zones. Evidently one (or more) of these Zones have an active connection to the database, but if you have changed the port number you will have to reflect that in the Zone configuration.

Cheers
Lapo
--
gotoAndPlay()
...addicted to flash games
lazybearsoft
Posts: 4
Joined: 15 Apr 2020, 00:59

Re: Added H2EnginePort directive, now won't connect

Postby lazybearsoft » 15 Apr 2020, 19:30

Lapo, that fixed it....I had seen many posts that mentioned the first place you had to override the port number, but not the second....so I had missed it. Thanks a million!!!

Return to “SmartFoxServer 1.x Discussions and Help”

Who is online

Users browsing this forum: Bing [Bot] and 30 guests